System requirements for NAB Connect


To get the most out of NAB Connect we recommend you meet these minimum system requirements:

Desktop requirements

Operating system

Windows® 10, 8, 7, Vista, XP (SP3 or later); Mac OS X v10.6.

NAB Connect doesn’t support Linux operating systems. You may have trouble using NAB Connect on Linux.

Browser

  • Google Chrome (latest version and the version before)
  • Firefox™ (latest version and the version before)
  • Microsoft Edge (latest version and version minus last)
  • Safari (latest version and version minus last)

Screen resolution

1024 x 768 or greater

Security software

Never access NAB Connect on a computer you think may be infected with a virus. Always ensure you have up-to-date anti-virus, anti-spyware and firewall software installed. For more specific information about how to protect your computer, visit the Microsoft® Security & Privacy site.

Accessibility

NAB Connect is designed to work with JAWS and other screen reader software. Learn more about how NAB Connect supports screen readers.
 

Mobile requirements

iOS devices

Version iOS 11.0 or newer

Android devices

Android 5.1 or newer. Android users can only download and

activate the app in Australia, New Zealand, US, UK or Singapore.

 

Trademarks

Microsoft and Windows are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Apple and Macintosh are trademarks of Apple Computer, Inc., registered in the U.S. and other countries.

Firefox is a trademark of the Mozilla Foundation.

Safari is a registered trademark of Apple Computer, Inc., registered in the U.S. and other countries.